Winter-1-E Let the Balloon Rise 解题报告及测试数据

Time Limit:1000MS     Memory Limit:32768KB

Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

Sample Output

red

pink 

以下是代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <map>//使用字典容器
#include <string>
using namespace std;
int main(){
    int n,k,cnt[1005];
    char str[100];
    string t;
    while(scanf("%d",&n)!=EOF && n){
        map<string,int>ball;
        map<string, int>::iterator it;
        k=1;
        for(int i=0;i<1005;cnt[i]=1,i++);
        for(int i=0;i<n;i++){
            scanf("%s",str);
            t = str;
            if(ball.count(t))cnt[ball[t]]++;//存在,数量加一
            else ball[t]=k++;//不存在,将颜色映射为数字
        }
        int maxn=1;
        for(int i=2;i<n;i++)
            if(cnt[i]>cnt[maxn])maxn=i;
        for(it =  ball.begin();it!=ball.end();it++)
        if(it->second == maxn){
            cout << it->first<<endl;
            break;
        }
        ball.clear();
    }
}

  

原文地址:https://www.cnblogs.com/gzdaijie/p/4298090.html