poj 2109 Power of Cryptography

Power of Cryptography
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13314   Accepted: 6813

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

Source


这道题最大的难点就是给的数据太大了,用枚举肯定是不行的,然后本来想c库里有没有求高次根的,查了一下发现没有,不过这个可能和我查的资料有关(资料可能不全)。然后我就尝试用对数,因为对数往往可以将大数化为小数来处理,所以我就尝试了用对数来处理,果然过了。当然当中我们可能会怀疑10^101次方这个数怎么输入呢,这个我们一个是要用double来处理,其次要知道编译器一般只处理64位以内的整数,所以太长的数可定是用科学计数法来处理的,所以我不用担心这点,这是题目数据里肯定已经处理的东西。
#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;

int main()
{
    int n,k;
    double p;
    while((scanf("%d%lfd",&n,&p))!=EOF)
    {
        float s;
        s=log10(p)/n;
        float sum;
        sum=pow(10.0,s);
        int sum2;
        sum2=sum;
        printf("%d\n",sum2);   
    }
    system("pause");
    return 0;
}



原文地址:https://www.cnblogs.com/gremount/p/5768026.html