ACM YTU 挑战编程 字符串 Problem A: WERTYU

Problem A: WERTYU



Description

A common typing error is to place yourhands on the keyboard one row to the right of the correct position. Then ``Q'' is typed as ``W'' and ``J'' is typed as ``K'' and so on. Your task is to decode a message typed inthis manner.


Input

Input consists ofseveral lines of text. Each line may contain digits, spaces, uppercase letters(except ``Q'', ``A'', ``Z''), or punctuation shown above [except back-quote(`)]. Keys labeled with words [Tab, BackSp, Control, etc.] are not representedin the input.


Output

You are to replaceeach letter or punctuation symbol by the one immediately to its left on theQWERTY keyboard shown above. Spaces in the input should be echoed in theoutput.


Sample Input

O S, GOMR YPFSU/


Sample Output

I AM FINE TODAY.


 

/**
*   水题
*   提议就是输入一串字符,输出它在 键盘上前一位的字符  如  输入U  输出的就是Y
*   ps:QAZ除外   空格原样输出
*
*/
#include <iostream>
using namespace std;
int main()
{
    string s = "`1234567890-=QWERTYUIOP[]\ASDFGHJKL;'ZXCVBNM,./";
    string line;
    while(getline(cin,line))
    {
        for(int i = 0;i<int(line.length());i++)
        {
            if(line[i]==' ')
                cout<<" ";
            else
                cout<<s[s.find_first_of(line[i])-1];
/**
*   string 类的一个成员函数
*   s.find_first_of(line[i])
*   找到 line[i] 在(string)s中出现的第一个值并返回(返回类型为int),没有就返回如果没找到就返回string::npos
*   详情参考 http://blog.163.com/chen_dawn/blog/static/1125063201111191617784/
*/
        }
        cout<<endl;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/gray1566/p/3704307.html