查找最大元素

Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
 
Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
 
Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
 
Sample Input
abcdefgfedcba
xxxxx
 
Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)
 
code:

#include<stdio.h>
#include<string.h>
int main()
{
          int len,i;
         char s[106],c;
         while(scanf("%s",s)!=EOF)
         {
               len=strlen(s);
               c=s[0];
               for(i=0;i<len;i++)
                  if(c<s[i])
                     c=s[i];
               for(i=0;i<len;i++)
               {
                     printf("%c",s[i]);
                     if(s[i]==c)
                         printf("(max)");
              }
         printf(" ");
       }
     return 0;
}

 
 
 
 
 
原文地址:https://www.cnblogs.com/gongpulin/p/3894098.html