poj1979(Red and Black)

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

简单深搜

#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;
const int INF = 0x3f3f3f3f;
const double PI = acos(-1.0);
int dx[] = {0, 1, 0, -1}, dy[] = {-1, 0, 1, 0};
const int maxn = 25;

int h, w;
char s[maxn][maxn];
int sx, sy;

bool range(int x, int y)
{
    return x >= 0 && x < h && y >= 0 && y < w;
}

int dfs(int x, int y)
{
    int ans = 1;
    s[x][y] = '#';
    for (int i = 0; i < 4; ++i)
        if (range(x+dx[i], y+dy[i]) && s[x+dx[i]][y+dy[i]] == '.')
            ans += dfs(x+dx[i], y+dy[i]);
    return ans;
}


int main()
{
    while (cin >> w >> h && (w || h))
    {
        for (int i = 0; i < h; ++i)
        {
            scanf("%s", s[i]);
            for (int j = 0; j < w; ++j)
                if (s[i][j] == '@')
                {
                    sx = i;
                    sy = j;
                }
        }
        cout << dfs(sx, sy) << endl;
    }
    return 0;
}


原文地址:https://www.cnblogs.com/godweiyang/p/12203991.html