PTA 01-复杂度2 Maximum Subsequence Sum (25分)

题目地址

https://pta.patest.cn/pta/test/16/exam/4/question/663

5-1 Maximum Subsequence Sum   (25分)

Given a sequence of KK integers { N_1N1​​, N_2N2​​, ..., N_KNK​​ }. A continuous subsequence is defined to be { N_iNi​​, N_{i+1}Ni+1​​, ..., N_jNj​​ } where 1 le i le j le K1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KK (le 1000010000). The second line contains KK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices ii and jj (as shown by the sample case). If all the KK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4



/*评测结果
时间	结果	得分	题目	编译器	用时(ms)	内存(MB)	用户
2017-07-08 15:45	正在评测	0	5-1	gcc	无	无	
测试点结果
测试点	结果	得分/满分	用时(ms)	内存(MB)
测试点1	答案正确	13/13	2	1
测试点2	答案正确	2/2	1	1
测试点3	答案正确	2/2	1	1
测试点4	答案正确	2/2	1	1
测试点5	答案正确	2/2	1	1
测试点6	答案正确	2/2	1	1
测试点7	答案错误	0/1	1	1
测试点8	答案正确	1/1	3	1

不知道什么情况,卡了一个测试点
*/
#include<stdio.h>
int main()
{
	int i,k;
	int getNum,lastGetNum=-1,max=0;
	int tempfirst=0,first=0,last=0;
	int allNegtiveFlag=1,sum=0;
	scanf("%d",&k);
	for(i=0;i<k;i++)
	{	scanf("%d",&getNum);
		if(getNum>=0) allNegtiveFlag=0;
		if (i==0) first=getNum;
		if (sum==0 && getNum>0){
//			if(lastGetNum!=0)
				tempfirst=getNum;
		}
		sum+=getNum;
		if (sum<0) 
			sum=0;
		if (sum>max){
			max=sum;
			first=tempfirst;
			last=getNum;
		}
//		lastGetNum=getNum;
		if(i==k-1 && max==0 && allNegtiveFlag==1)
			last=getNum;
				
	}
		if(max==0 && allNegtiveFlag==0){
		first=0;
		last=0;
		}
		
	printf("%d %d %d",max,first,last);
}

  

原文地址:https://www.cnblogs.com/gk2017/p/7140502.html