hdoj-1213-How Many Tables【并查集】

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17892 Accepted Submission(s): 8794


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5

Sample Output
2 4

Author
Ignatius.L

Source

Recommend
Eddy | We have carefully selected several similar problems for you: 1856 1325 1102 1301 1116

#include<stdio.h> 
int root[1010];
int find(int i){
	if(root[i]==i) return i;
	return root[i]=find(root[i]);
}
void unio(int i,int j){
	if(find(i)<=find(j)) root[j]=find(i);
	else root[i]=find(j);
	return;
}
int main(){
	int  t;
	scanf("%d",&t);
	while(t--){
		int n,m,i,x,y,nu=0;
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;++i) root[i]=i;
		for(i=1;i<=m;++i){
		  scanf("%d%d",&x,&y);
		  if(find(x)!=find(y))
		     unio(find(x),find(y));
		     //unio(x,y);  //此处写法是错误的,在这里WA了多次!

!!!!

!!

!。!!!!改动的应是各自的根 } for(i=1;i<=n;++i){ if(root[i]==i) nu++; } printf("%d ",nu); } return 0; }



原文地址:https://www.cnblogs.com/gccbuaa/p/6747122.html