USACO Dining Cows

USACO Dining Cows

洛谷传送门

JDOJ传送门

Description

The cows are so very silly about their dinner partners. They have
organized themselves into two groups (conveniently numbered 1 and
2) that insist upon dining together in order, with group 1 at the
beginning of the line and group 2 at the end. The trouble starts
when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved D_i
(1 <= D_i <= 2) indicating her dining group membership. The entire
set of N (1 <= N <= 30,000) cows has lined up for dinner but it's
easy for anyone to see that they are not grouped by their dinner-partner
cards.

FJ's job is not so difficult. He just walks down the line of cows
changing their dinner partner assignment by marking out the old
number and writing in a new one. By doing so, he creates groups of
cows like 112222 or 111122 where the cows' dining groups are sorted
in ascending order by their dinner cards. Rarely he might change
cards so that only one group of cows is left (e.g., 1111 or 222).

FJ is just as lazy as the next fellow. He's curious: what is the
absolute minimum number of cards he must change to create a proper
grouping of dining partners? He must only change card numbers and
must not rearrange the cows standing in line.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 describes cow i's dining preference with a
single integer: D_i

Output

* Line 1: A single integer that is the minimum number of cards Farmer
John must change to assign the cows to eating groups as
described.

Sample Input

7 2 1 1 1 2 2 1

Sample Output

2

HINT

INPUT DETAILS:

Seven cows; all but three of which currently prefer dining group 1.

OUTPUT DETAILS:

Change the first and last cow's cards.


题解:

DP水题。

Code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int d[30010];
int dp[30005][2];
int main(){
    int n,i;
    cin>>n;
    for (i=1;i<=n;++i){
        cin>>d[i];
    }
    dp[1][2-d[1]]=1;
    dp[1][d[1]-1]=0;
    for (i=2;i<=n;++i){
        if (d[i]==1){
            dp[i][0]=dp[i-1][0];
            dp[i][1]=min(dp[i-1][1],dp[i-1][0])+1;
        }else{
            dp[i][0]=dp[i-1][0]+1;
            dp[i][1]=min(dp[i-1][1],dp[i-1][0]);
        }
    }
    if (dp[n][0]>dp[n][1]) printf("%d",dp[n][1]);
    else printf("%d",dp[n][0]);
    return 0;
}
原文地址:https://www.cnblogs.com/fusiwei/p/13738990.html