POJ 3624【水01背包】

原题链接:http://poj.org/problem?id=3624

我的链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=20437#problem/A欢迎来水

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14963   Accepted: 6840

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source


裸01背包。。。一切重头开始吧

题意:第一行的两个整数和 分别表示可选择放入的物品有n个,背包体积为m

      接下来 n行每行的前一个整数代表当前物品放入背包的体积和产生的价值。

      每种物品只可以放一次,求放入物品总体积不超过背包总体积情况下可以产生的最大                       

      价值。

算法:01背包。。。一切重头开始吧

状态转移方程:

for i=1..N

    ZeroOnePack(c[i],w[i]);

    for v=V..cost

        f[v]=max{f[v],f[v-cost]+weight}


//Accepted	216 KB	297 ms	C++	343 B	2013-03-13 22:00:10
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 12880 + 10;
int dp[maxn];

int main()
{
	int n,m;
	int w,d;
	scanf("%d%d", &n, &m);
	for(int i =1; i <= n; i++)
	{
		scanf("%d%d", &w, &d);
		for(int j = m; j >=w; j--)
		{
			dp[j] = max(dp[j],dp[j-w]+d);
		}
	}
	printf("%d\n", dp[m]);
	return 0;
}



原文地址:https://www.cnblogs.com/freezhan/p/2974232.html