pat 1003

1003 Emergency (25分)

 

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between c1 and c2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题意 :给定一个无向带权图,并且给定结点的权值,求从给定顶点c1到给定顶点c2的最短路径的条数以及 所有最短路径中 最大的各顶点权值之和

思路:建图,dijkstra算法求最短路径,num数组保存最短路径条数。weight数组保存从c1到某个顶点的所有最短路径上顶点权值之和的最大值。

代码如下:

#include<cstdio>
#include<algorithm>
#include<vector>
#define inf 9999
using namespace std;
int G[505][505]={0};
int teams[505]={0};
int dist[505]; 
int visited[505]={0};
vector<int> path[505];
int weight[505]={0};
int num[505];
int n;
int findMin(){
    int min=-1;
    int minDist=inf;
    for(int i=0;i<n;i++){
        if(dist[i]<minDist&&visited[i]==false){
            minDist=dist[i];
            min=i;
        }
    }
    return min;
}
void dijkstra(int v,int s){
    fill(dist,dist+n,inf);
    dist[v]=0;
    visited[v]=1;
    for(int i=0;i<n;i++){
        if(G[v][i]<inf){
            dist[i]=G[v][i];    
            weight[i]+=weight[v];
        }
        num[i]=1;
    }
    while(1){
        int temp=findMin();
        if(temp==-1)
            break;
        visited[temp]=1;
        for(int i=0;i<n;i++){
            if(visited[i]==false){
                if(dist[temp]+G[temp][i]<dist[i]){
                    dist[i]=dist[temp]+G[temp][i];
                    num[i]=num[temp];
                    weight[i]=teams[i]+weight[temp];
                }
                else if(dist[temp]+G[temp][i]==dist[i]){
                    num[i]+=num[temp];
                    if(weight[i]<weight[temp]+teams[i]){
                        weight[i]=weight[temp]+teams[i];
                    }
                }
            }
        }
    }
    printf("%d %d",num[s],weight[s]);
}
int main(){
    fill(&G[0][0],&G[501][501],inf);
    int m,c1,c2;
    scanf("%d%d%d%d",&n,&m,&c1,&c2);
    for(int i=0;i<n;i++){
        scanf("%d",&teams[i]);
        weight[i]=teams[i];
    }
    int a,b,dis;
    for(int i=0;i<m;i++){
        scanf("%d%d%d",&a,&b,&dis);
        G[a][b]=G[b][a]=dis;
    }
    dijkstra(c1,c2);
    return 0;
} 
原文地址:https://www.cnblogs.com/foodie-nils/p/13340591.html