pat 1148

1148 Werewolf - Simple Version (20分)

 

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5). Then N lines follow and the i-th line gives the statement of the i-th player (1), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences [ and [, if there exists 0 such that [ (i≤k) and [, then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

题意:给定n个人的发言,每个人都会说n个人中的一个人是好人或者狼人,正数表示好人,负数表示狼人。所有人中只有两个人说的话是假话并且其中一个说假话的人是狼人,n个人中只有 两个狼人,要求找出这两个狼人。

思路:vector保存每个人的发言,双重循环,每次循环假定i和j是狼人(i取值从1到n-1,j取值从i+1到n),用数组a保存每个人的身份,1表示好人,-1表示狼人。判断在i和j是狼人的情况下说谎的人数,说谎的人用一个vector2保存,所有发言判断完成之后检查vector2的size,即检测说谎人数,如果是2人进一步判断这两个人中是否一个是狼人一个是好人(通过a[i]+a[j]是否等于0来判断)。

代码如下:

#include<cstdio>
#include<vector>
#include<algorithm> 
using namespace std;
vector<int> v;
vector<int> lier;
int main(){
    int n;
    scanf("%d",&n);
    v.resize(n+1);
    for(int i=1;i<=n;i++){
        scanf("%d",&v[i]);
    }
    for(int i=1;i<n;i++){
        for(int j=i+1;j<=n;j++){
            int a[n+1]={0};
            fill(a+1,a+n+2,1);
            a[i]=a[j]=-1;
            lier.clear();
            for(int k=1;k<=n;k++){
                if(v[k]*a[abs(v[k])]<0){
                    lier.push_back(k);
                }
                    
            }
            if(lier.size()==2){
                if(a[lier[0]]+a[lier[1]]==0){
                    printf("%d %d",i,j);
                    return 0;
                }
            }
        }
    }
    printf("No Solution");
    return 0;
}
原文地址:https://www.cnblogs.com/foodie-nils/p/13329775.html