POJ 1151 Atlantis

Atlantis
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24566   Accepted: 9116

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 
The input file is terminated by a line containing a single 0. Don't process it.

Output

For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

题目链接
参考自:https://blog.csdn.net/u013480600/article/details/39322791


题意
给你n个矩形,求他们的总面积之和

分析

直接离散化,所有矩形的边界延伸将空间分隔成许多小矩形,我们需要的就是找出这些小矩形。将坐标离散化,排序后去重,
然后逐个大矩形来计算哪些小矩形被包含了,定义mp[i][j]为以(x[i],y[i])为左下角(原文这里应该是打错了),(x[i+1],y[j+1])为右上角的小矩形。
最后我们只需找出mp[i][j]==true的矩形并计算面积即可。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include <queue>
#include <vector>
#include<bitset>
#include<map>
#include<deque>
using namespace std;
typedef long long LL;
const int maxn = 300;
const int mod = 77200211+233;
typedef pair<int,int> pii;
#define X first
#define Y second
#define pb push_back
//#define mp make_pair
#define ms(a,b) memset(a,b,sizeof(a))
const int inf = 0x3f3f3f3f;
#define lson l,m,2*rt
#define rson m+1,r,2*rt+1

struct Node{
    double x1,y1,x2,y2;
}node[maxn];
double x[maxn],y[maxn];
bool mp[maxn][maxn];

int bfind(double *a,double x,int n){
    int l=0,r=n-1,m;
    while(r>=l){
        m=(r+l)>>1;
        if(a[m]==x) return m;
        else if(a[m]<x) l=m+1;
        else r=m-1;
    }
    return -1;
}

int main(){
    int n,n1,n2,cas=0;
    while(scanf("%d",&n)==1&&n){
        n1=n2=0;
        ms(mp,false);
        for(int i=0;i<n;i++){
            scanf("%lf%lf%lf%lf",&node[i].x1,&node[i].y1,&node[i].x2,&node[i].y2);
            x[n1++]=node[i].x1;
            x[n1++]=node[i].x2;
            y[n2++]=node[i].y1;
            y[n2++]=node[i].y2;
        }
        sort(x,x+n1);
        sort(y,y+n2);
        n1=unique(x,x+n1)-x;
        n2=unique(y,y+n2)-y;

        for(int i=0;i<n;i++){
            int Lx=bfind(x,node[i].x1,n1);
            int Rx=bfind(x,node[i].x2,n1);
            int Ly=bfind(y,node[i].y1,n2);
            int Ry=bfind(y,node[i].y2,n2);

            for(int k=Lx;k<Rx;k++){
                for(int j=Ly;j<Ry;j++){
                    mp[k][j]=true;
                }
            }
        }
        double ans=0;
        for(int i=0;i<n1;i++){
            for(int j=0;j<n2;j++){
                if(mp[i][j]){
                    ans += (x[i+1]-x[i])*(y[j+1]-y[j]);
                }
            }
        }
        printf("Test case #%d
Total explored area: %.2f

",++cas,ans);
    }
}
其实还能用线段树扫描线来解决,实质上都是离散化。
参考:http://www.cnblogs.com/scau20110726/archive/2013/04/12/3016765.html
即用线段树来记录覆盖的区间长度。详情看链接和代码
#include<stdio.h>  
#include<iostream>  
#include<algorithm>  
using namespace std;  
#define MAXN 201  
struct Node  
{  
    int l,r;//线段树的左右整点  
    int c;//c用来记录重叠情况  
    double cnt,lf,rf;//  
    //cnt用来计算实在的长度,rf,lf分别是对应的左右真实的浮点数端点   
}segTree[MAXN*3];       
struct Line  
{  
    double x,y1,y2;  
    int f;  
}line[MAXN];  
//把一段段平行于y轴的线段表示成数组 ,  
//x是线段的x坐标,y1,y2线段对应的下端点和上端点的坐标   
//一个矩形 ,左边的那条边f为1,右边的为-1,  
//用来记录重叠情况,可以根据这个来计算,nod节点中的c   
  
bool cmp(Line a,Line b)//sort排序的函数  
{  
    return a.x < b.x;  
}       
  
double y[MAXN];//记录y坐标的数组  
void Build(int t,int l,int r)
{  
    segTree[t].l=l;segTree[t].r=r;  
    segTree[t].cnt=segTree[t].c=0;  
    segTree[t].lf=y[l];  
    segTree[t].rf=y[r];  
    if(l+1==r)  return;  
    int mid=(l+r)>>1;  
    Build(t<<1,l,mid);  
    Build(t<<1|1,mid,r);
}       
void calen(int t)//计算长度  
{  
    if(segTree[t].c>0)  
    {  
        segTree[t].cnt=segTree[t].rf-segTree[t].lf;  
        return;  
    }      
    if(segTree[t].l+1==segTree[t].r)  segTree[t].cnt=0;  
    else  segTree[t].cnt=segTree[t<<1].cnt+segTree[t<<1|1].cnt;  
}       
void update(int t,Line e)//加入线段e,后更新线段树  
{  
    if(e.y1==segTree[t].lf&&e.y2==segTree[t].rf)  
    {  
        segTree[t].c+=e.f;  
        calen(t);  
        return;  
    }      
    if(e.y2<=segTree[t<<1].rf)  update(t<<1,e);  
    else if(e.y1>=segTree[t<<1|1].lf)  update(t<<1|1,e);  
    else  
    {  
        Line tmp=e;  
        tmp.y2=segTree[t<<1].rf;  
        update(t<<1,tmp);  
        tmp=e;  
        tmp.y1=segTree[t<<1|1].lf;  
        update(t<<1|1,tmp);  
    }      
    calen(t);  
}      
int main()  
{  
    int i,n,t,iCase=0;  
    double x1,y1,x2,y2;  
    while(scanf("%d",&n),n)  
    {  
        iCase++;  
        t=1;  
        for(i=1;i<=n;i++)  
        {  
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);  
            line[t].x=x1;  
            line[t].y1=y1;  
            line[t].y2=y2;  
            line[t].f=1;  
            y[t]=y1;  
            t++;  
            line[t].x=x2;  
            line[t].y1=y1;  
            line[t].y2=y2;  
            line[t].f=-1;  
            y[t]=y2;  
            t++;  
        }   
        sort(line+1,line+t,cmp);  
        sort(y+1,y+t);     
        Build(1,1,t-1);  
        update(1,line[1]);  
        double res=0;  
        for(i=2;i<t;i++)  
        {  
            res+=segTree[1].cnt*(line[i].x-line[i-1].x);  
            update(1,line[i]);  
        }      
        printf("Test case #%d
Total explored area: %.2f

",iCase,res);  
   
    }      
    return 0;  
}     


  


原文地址:https://www.cnblogs.com/fht-litost/p/8627837.html