HDU 4352 XHXJ's LIS 数位dp

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=4352

XHXJ's LIS

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)
#### 问题描述 > define xhxj (Xin Hang senior sister(学姐)) > If you do not know xhxj, then carefully reading the entire description is very important. > As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu. > Like many god cattles, xhxj has a legendary life: > 2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final. > As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type. > Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls. > Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time. > For the first one to solve this problem,xhxj will upgrade 20 favorability rate。 #### 输入 > First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.( > 0

For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.

样例输入

1
123 321 2

样例输出

Case #1: 139

题意

求L,R区间内满足数位由高位到低位严格上升子序长度为k的数有多少个。
比如 满足[100,105],k=2的数有:101、102、103、104、105

题解

利用二分求lis的思想,由于数范围只有0到9,我们可以吧用来二分的那个单调数组状压起来,然后利用lis的转移方程去转移:比如现在有状态{1,2,6},单前位的值为3,那么状态会变成{1,2,3}。

dp[len][mask][k]表示前len位,压缩的状态为mask。

代码

#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<stack>
#include<ctime>
#include<vector>
#include<cstdio>
#include<string>
#include<bitset>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
#define X first
#define Y second
#define mkp make_pair
#define lson (o<<1)
#define rson ((o<<1)|1)
#define mid (l+(r-l)/2)
#define sz() size()
#define pb(v) push_back(v)
#define all(o) (o).begin(),(o).end()
#define clr(a,v) memset(a,v,sizeof(a))
#define bug(a) cout<<#a<<" = "<<a<<endl
#define rep(i,a,b) for(int i=a;i<(b);i++)
#define scf scanf
#define prf printf

typedef long long LL;
typedef vector<int> VI;
typedef pair<int,int> PII;
typedef vector<pair<int,int> > VPII;

const int INF=0x3f3f3f3f;
const LL INFL=0x3f3f3f3f3f3f3f3fLL;
const double eps=1e-8;
const double PI = acos(-1.0);

//start----------------------------------------------------------------------

int arr[22],tot;
///ismax标记表示前驱是否是边界值
///ser标记前驱是否是前导零
LL dp[22][(1<<10)+10][11];
LL dfs(int len,int mask, int k,bool ismax,bool iszer) {
    if (len == 0) {
        ///递归边界
        int cnt=0;
        for(int i=0;i<10;i++) if(mask&(1<<i)) cnt++;
        return LL(cnt==k);
    }
    if (!ismax&&dp[len][mask][k]>=0) return dp[len][mask][k];
    LL res = 0;
    int ed = ismax ? arr[len] : 9;
 
    ///这里插入递推公式
    for (int i = 0; i <= ed; i++) {
        if(i==0&&iszer){
            res+=dfs(len-1,0,k,ismax&&i==ed,iszer&&i==0);
        }else{
            int ne=-1;
            //lis的转移方程 
            for(int j=i;j<10;j++) if(mask&(1<<j)){
                ne=j; break;
            }
            int tmp=mask|(1<<i);
            if(ne>i) tmp^=(1<<ne);
            res += dfs(len - 1, tmp,k, ismax&&i == ed,iszer&&i==0);
        }
    }
    return ismax ? res : dp[len][mask][k] = res;
}

LL solve(LL x,int k) {
    tot = 0;
    while (x) { arr[++tot] = x % 10; x /= 10; }
    return dfs(tot, 0,k, true,true);
}


int main() {
    clr(dp,-1);
    int tc,kase=0;
    scanf("%d",&tc);
    while(tc--){
        LL L,R;
        int K;
        scf("%lld%lld%d",&L,&R,&K);
        prf("Case #%d: %lld
",++kase,solve(R,K)-solve(L-1,K));
    }
    return 0;
}

//end-----------------------------------------------------------------------
原文地址:https://www.cnblogs.com/fenice/p/5906348.html