Max Sum Plus Plus——A

                                                  A. Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

Output

Output the maximal summation described above in one line.
 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3 (子段1: 4;子段2:3 -2 3)

Sample Output

6
8

Hint

Huge input, scanf and dynamic programming is recommended.
 
题意:求最大M子段和
#include <iostream>
#include<cmath>
#include<cstring>
using namespace std;
const int MAX=1000010;
const int INF=0x7fffffff;
int a[MAX];
int b[MAX];
int c[MAX];
int main()
{
    int m,n;
    while(cin>>n>>m)
    {
        for(int i=1;i<=m;i++)
            cin>>a[i];
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        int maxn;
        for(int i=1;i<=n;i++)
        {
            maxn=(-1)*INF;
            for(int j=i;j<=m;j++)
            {
                b[j]=max(b[j-1]+a[j],c[j-1]+a[j]);
                c[j-1]=maxn;
                if(b[j]>maxn)
                    maxn=b[j];
            }
        }
        cout<<maxn<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/fenhong/p/5290703.html