反片语(map)

输入一些单词,找出所有满足如下条件的单词:

该单词不能通过字母重排,得到输入文本中的另外一个单词。

在判断是否满足条件时,不区分大小写,但输出保留输入中的大小写,按字典序进行排列(所有大写字母在小写字母的前面)

样例输入:

ladder came tape soon leader acme RIDE lone Dreis peat

ScALE orb eye Rides dealer NotE derail LaCeS drIed

noel dire Disk mace Rob dires

#

样例输出:

Disk
NotE
derail
drIed
eye
ladder
soon

分析:把每个单词“标准化”,即全部转化为小写字母后再进行排序,然后再放到map中进行统计

#include<iostream>
#include<string>
#include<cctype>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
map<string,int>cnt;
vector<string>words;

string repr(const string & s)             //将单词s进行标准化
{
    string ans=s;
    for(int i=0;i<ans.length();i++)
        ans[i]=tolower(ans[i]);
    sort(ans.begin(),ans.end());           //sort可以对任意对象进行排序
    return ans;
}
int main() 
{
    int n=0;
    string s;
    while(cin>>s){
        if(s[0]=='#')break;
        words.push_back(s);              //在vector words尾部加入一个数据s
        string r=repr(s);             //r为标准化后的字符串
        if(!cnt.count(r))cnt[r]=0;        //count(n) 返回容器中n出现的次数   若为0,则将r存入容器中,并初始个数为0
        cnt[r]++;                               //r对应的int个数 加一 ,该值即为r出现的次数
    }
    vector<string>ans;
    for(int i=0;i<words.size();i++)
        if(cnt[repr(words[i])]==1)ans.push_back(words[i]);        
    sort(ans.begin(),ans.end());
    for(int i=0;i<ans.size();i++)cout<<ans[i]<<endl;
    //system("pause");
    return 0;
}
原文地址:https://www.cnblogs.com/farewell-farewell/p/5231966.html