hdu 1305 Immediate Decodability(字典树)

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1378    Accepted Submission(s): 706

Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 
Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 
Sample Input
01 10 0010 0000 9 01 10 010 0000 9
 
Sample Output
Set 1 is immediately decodable Set 2 is not immediately decodable
 
Source

import java.util.Scanner;

public class Main {//字典树
	private static Node node = null;
	private static Node root = new Node();
	private static int cases = 0;

	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		while (input.hasNext()) {
			root = new Node();//根节点
			node = root;
			++cases;
			boolean ok = true;
			String str = "";
			while (!("9".equals((str = input.next())))) {
				node = root;//返回开始节点
				for (int i = 0; i < str.length(); ++i) {
					if ('0' == str.charAt(i)) {// lchild,如果是0进入左孩子
						if (null == node.getLchild()) {//如果左孩子是null,创建一个新根节点
							Node gen = new Node();//创建新根节点
							if (i == str.length() - 1) {//如果是最后一个,则标记成叶子节点
								gen.setValue(true);
							}
							node.setLchild(gen);//向下传递
							node = gen;
						} else {
							node = node.getLchild();//如果不为空,直接向下传递
							if (node.isValue()) {//如果传递过程中出现叶子节点,则ok直接是false
								ok = false;
							}
						}
					} else {// rchild,如果是1,跟上边一样,只是把左换成右
						if (null == node.getRchild()) {
							Node gen = new Node();
							if (i == str.length() - 1) {
								gen.setValue(true);
							}
							node.setRchild(gen);
							node = gen;
						} else {
							node = node.getRchild();
							if (node.isValue()) {
								ok = false;
							}
						}
					}
				}
			}
			if (ok) {//输出
				System.out.println("Set " + cases + " is immediately decodable");
			} else
				System.out.println("Set " + cases+ " is not immediately decodable");
		}
	}
}

class Node {//创建二叉树
	boolean value = false;
	Node lchild;
	Node rchild;
	
	//一些get和set方法
	public boolean isValue() {
		return value;
	}

	public void setValue(boolean value) {
		this.value = value;
	}

	public Node getLchild() {
		return lchild;
	}

	public void setLchild(Node lchild) {
		this.lchild = lchild;
	}

	public Node getRchild() {
		return rchild;
	}

	public void setRchild(Node rchild) {
		this.rchild = rchild;
	}

}



原文地址:https://www.cnblogs.com/dyllove98/p/3236927.html