uva-11234 Expressions

Arithmetic expressions are usually written with the operators in between the two operands (which is called infix notation). For example,(x+y)*(z-w) is an arithmetic expression in infix notation. However, it is easier to write a program to evaluate an expression if the expression is written in postfix notation (also known as reverse polish notation). In postfix notation, an operator is written behind its two operands, which may be expressions themselves. For example, x y + z w - * is a postfix notation of the arithmetic expression given above. Note that in this case parentheses are not required.

To evaluate an expression written in postfix notation, an algorithm operating on a stack can be used. A stack is a data structure which supports two operations:

  1. push: a number is inserted at the top of the stack.
  2. pop: the number from the top of the stack is taken out.

During the evaluation, we process the expression from left to right. If we encounter a number, we push it onto the stack. If we encounter an operator, we pop the first two numbers from the stack, apply the operator on them, and push the result back onto the stack. More specifically, the following pseudocode shows how to handle the case when we encounter an operator O:

a := pop();
b := pop();
push(b O a);

The result of the expression will be left as the only number on the stack.

Now imagine that we use a queue instead of the stack. A queue also has a push and pop operation, but their meaning is different:

  1. push: a number is inserted at the end of the queue.
  2. pop: the number from the front of the queue is taken out of the queue.

Can you rewrite the given expression such that the result of the algorithm using the queue is the same as the result of the original expression evaluated using the algorithm with the stack?

Input Specification

The first line of the input contains a number T (T ≤ 200). The following T lines each contain one expression in postfix notation. Arithmetic operators are represented by uppercase letters, numbers are represented by lowercase letters. You may assume that the length of each expression is less than 10000 characters.

Output Specification

For each given expression, print the expression with the equivalent result when using the algorithm with the queue instead of the stack. To make the solution unique, you are not allowed to assume that the operators are associative or commutative.

Sample Input

2
xyPzwIM
abcABdefgCDEF

Sample Output

wzyxIPM
gfCecbDdAaEBF
题目意思:求一个字符序列,该序列使得当它使用队列且使用与栈相同的操作序列,表达示结果一样。
解题思路:当你建立表达示树的时候,不难发现一个规律,所求的字符序列是表达示树的层序遍历产生的序列的逆序。
所以我们先建树,然后层序遍历就行了。
#include <iostream>
#include<deque>
#include<algorithm>
#include<cstdio>
#include<stack>
#include<string>
#include<vector>
#include<map>
#include<sstream>
#include<cctype>
#include<queue>
using namespace std;

struct node
{
    char data;
    node*left;
    node*right;
    node(int d):data(d),left(0),right(0){};
};

node* build(string s)
{
    stack<node*>st;
    for(unsigned i=0;i<s.size();i++)
    {
        if(isupper(s[i]))
        {
            node*right=st.top();st.pop();
            node*left=st.top();st.pop();
            node*root=new node(s[i]);
            root->right=right;
            root->left=left;
            st.push(root);
        }
        else
        {
            st.push(new node(s[i]));
        }
    }
    return st.top();
}

string get_ans(node* root)
{
    queue<node*>q;
    q.push(root);
    string ans;
    while(!q.empty())
    {
        node*cur=q.front();q.pop();
        ans+=cur->data;
        if(cur->left)q.push(cur->left);
        if(cur->right)q.push(cur->right);
    }
    reverse(ans.begin(),ans.end());
    return ans;
}

int main()
{
    int n;
    string s;
    cin>>n;
    while(n--)
    {
        string ans;
        cin>>s;
        node* root=build(s);
        cout<<get_ans(root)<<endl;
    }
    return 0;
}


原文地址:https://www.cnblogs.com/dyllove98/p/3172164.html