栈练习3

3139 栈练习3

 

 时间限制: 2 s
 空间限制: 128000 KB
 题目等级 : 黄金 Gold
 
 
 
题目描述 Description

比起第一题,本题加了另外一个操作,访问栈顶元素(编号3,保证访问栈顶元素时或出栈时栈不为空),现在给出这N此操作,输出结果。

输入描述 Input Description

N

N次操作(1入栈 2出栈 3访问栈顶)

输出描述 Output Description

K行(K为输入中询问的个数)每次的结果

样例输入 Sample Input

6

1  7

3

2

1  9

1  7

3

样例输出 Sample Output

7

7

数据范围及提示 Data Size & Hint

 对于50%的数据 N≤1000 入栈元素≤200

 对于100%的数据 N≤100000入栈元素均为正整数且小于等于10^4 

#include<iostream>
using namespace std;
int f[101],n,x,y,m=1;
int main()
{
    cin>>n;
    for(int i=1; i<=n; i++)
    {
        cin>>x;
        if(x==1)
        {
            cin>>y; 
            f[m++]=y;
        } 
        if(x==2)
        {
            f[m-1]=0;
            m--;
        }
        if(x==3)
        {
            cout<<f[m-1]<<endl;
        }
    }
    /*if(f[m-1]!=0)
        cout<<f[m-1];
    else
        cout<<"impossible!";*/
    return 0;
}
原文地址:https://www.cnblogs.com/dxy1174868024/p/5470130.html