1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17
 

Sample Output:

7

题解:
给出n个整数,找出不在列表中的最小的正整数
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int main(){
    map<int,int> mp;
    int n,m;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>m;
        mp[m]++;
    }
    for(int i=1;i<0x3fffffff;i++){
        if(mp[i]==0){
            cout<<i<<endl;
            return 0;
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/dreamzj/p/14410072.html