1027 Colors in Mars (20分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71
 

Sample Output:

#123456


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<set>
#include<cmath>
#include<cstring>
#include<queue>
#include<string.h>
using namespace std;
const int maxn=1010;
typedef long long ll;
const int inf=0x3fffffff;
vector<char> v;
char k(int n){
    if(n==10){
        return 'A';
    }
    if(n==11){
        return 'B';
    }
    if(n==12){
        return 'C';
    }
    if(n<12){
        return n+48;
    }
}
void cc(int n){
    int temp;
    if(n==0){
        printf("00");
    }
    while(n>0){
        temp=n%13;
        v.push_back(k(temp));
        n/=13;
    }
    if(v.size()==1){
        printf("0");
    }
    for(int i=v.size()-1;i>=0;i--){
        printf("%c",v[i]);
    }
    v.clear();
}

int main(){
    int a,b,c;
    scanf("%d %d %d",&a,&b,&c);
    printf("#");
    cc(a);
    cc(b);
    cc(c);
    return 0;
}

注意考虑a,b,c等于0的情况

代码优化:

#include<bits/stdc++.h>
using namespace std;
int main(){
    char s[14]="0123456789ABC";
    int a,b,c;
    scanf("%d %d %d",&a,&b,&c);
    printf("#");
    printf("%c%c",s[a/13],s[a%13]);
    printf("%c%c",s[b/13],s[b%13]);
    printf("%c%c",s[c/13],s[c%13]);
    return 0;
}
原文地址:https://www.cnblogs.com/dreamzj/p/14337602.html