1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
 

Sample Output:

10 1 4


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<cstdlib>
using namespace std;
#define mm 1e-8
const int maxn=100010;


int main(){
    int m[maxn];
    int n;
    cin>>n;
    int sum=0, max=-1, left=0, leftindex=0, right=n-1;
    for(int i=0;i<n;i++){
        cin>>m[i];
        sum+=m[i];
        if(sum<0){
            sum=0;            //i左边的全部抛弃 
            leftindex=i+1;        //left至少要在从下一个位置开始 
        }
        else if(sum>max){
            max=sum;
            left=leftindex;//无论sum>max还是sum<max ,左下标都不用动,只动右下标 
            right=i; 
        }
    }
    if(max<0){
        max=0;
    }
    cout<<max<<" "<<m[left]<<" "<<m[right]<<endl;
    return 0;
} 
原文地址:https://www.cnblogs.com/dreamzj/p/14275150.html