POJ1733 Parity game 【带权并查集】*

POJ1733 Parity game


Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even or odd (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even means an even number of ones and odd means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3


题意:
告诉你有一个长度为L的01串
然后告诉你n个询问和结果
询问一个区间中的1的个数是计数还是偶数
然后给出答案
问你前多少个答案是合法的

然后%yyf大神的并查集

我们可以把1的个数转化成前缀
然后对于一个区间[l,r],我们把它分成l-1和r,然后如果区间内是奇数,l-1和r奇偶性不同,如果是偶数,则这两个点的奇偶性相同
然后我们可以用带权并查集来维护
对于这道题就在并查集维护的时候把奇偶关系异或压缩一下就好了
然后判断一下当前的奇偶关系合不合法就好了


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define N 10010
#define pi pair<int,int>
#define f first
#define s second
int L,n,tot=0;
char str[10];
pi p[N],fa[N];
int pre[N];
bool relation[N];
int find(int x){
    if(fa[x].f==x)return x;
    int lastfa=fa[x].f;
    fa[x].f=find(fa[x].f);
    fa[x].s^=fa[lastfa].s;
    return fa[x].f;
}
int main(){
    scanf("%d%d",&L,&n);
    for(int i=1;i<=n;i++){
        scanf("%d%d%s",&p[i].f,&p[i].s,str);
        p[i].f--;
        pre[++tot]=p[i].f;
        pre[++tot]=p[i].s;
        relation[i]=(str[0]=='o');
    }
    sort(pre+1,pre+tot+1);
    tot=unique(pre+1,pre+tot+1)-pre-1;
    for(int i=1;i<=n;i++){
        p[i].f=lower_bound(pre+1,pre+tot+1,p[i].f)-pre;
        p[i].s=lower_bound(pre+1,pre+tot+1,p[i].s)-pre;
    }
    for(int i=1;i<=tot;i++)fa[i].f=i,fa[i].s=0;
    for(int i=1;i<=n;i++){
        int fa1=find(p[i].f),fa2=find(p[i].s);
        if(fa1==fa2){
            int tmp1=fa[p[i].f].s;
            int tmp2=fa[p[i].s].s;
            if((fa[p[i].f].s^fa[p[i].s].s)!=relation[i]){
                printf("%d",i-1);
                return 0;
            }
        }else{
            fa[fa1].s=relation[i]^fa[p[i].f].s;
            fa[fa1].f=p[i].s;
        }
    }
    printf("%d",n);
    return 0;
}
原文地址:https://www.cnblogs.com/dream-maker-yk/p/9676305.html