A water problem 大数取余。

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 424    Accepted Submission(s): 224


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year. 

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 
Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0N), the length of N is up to 10000000.
 
Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 
Sample Input
10001 0 333
 
Sample Output
Case #1: YES Case #2: YES Case #3: NO
 
Author
UESTC
 
Source
 
 
代码:

#include<stdio.h>
#include<string.h>
#define N 10000006

char s[N];

int main(void)
{
int n, i, j, d;
j = 0;
while(scanf("%s", s) != EOF)
{
j++;
n = 0;
d = 73 * 137; //两个星球年数的最小公倍数。

for(i = 0; s[i]; i++)
n = (n * 10 + (s[i] - '0' ) % d) % d;

if(n == 0)
printf("Case #%d: YES ", j);
else
printf("Case #%d: NO ", j);
}

}

 
 
Recommend
wange2014   |   We have carefully selected several similar problems for you:  5842 5841 5840 5839 5838 
原文地址:https://www.cnblogs.com/dll6/p/5771875.html