1011数的计算

1011 数的计算

 

2001年NOIP全国联赛普及组

 时间限制: 1 s
 空间限制: 128000 KB
 题目等级 : 白银 Silver
 
 
 
题目描述 Description

我们要求找出具有下列性质数的个数(包含输入的自然数n):

先输入一个自然数n(n<=1000),然后对此自然数按照如下方法进行处理:

1.          不作任何处理;

2.          在它的左边加上一个自然数,但该自然数不能超过原数的一半;

3.          加上数后,继续按此规则进行处理,直到不能再加自然数为止.

输入描述 Input Description

一个数n

输出描述 Output Description

满足条件的数的个数

样例输入 Sample Input

6

样例输出 Sample Output

6

数据范围及提示 Data Size & Hint

6个数分别是:

6

16

26

126

36

136

#include<iostream>
using namespace std;
int num;
void F(int x)
{
    for(int i = 0; i >= x / 2; i++)
    {
        if(i)
        {
            F(i);
            cout << i;
        }
        else
        {
            num ++;
        }
    }
}
int main()
{
    int x;
    while(cin >> x)
    {
        num = 0;
        F(x);
        cout << num << endl;
    }
}
原文地址:https://www.cnblogs.com/denghui666/p/7819836.html