HDU 2669 Romantic

Description

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 
 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 
 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3
 
313页。。
算法竞赛
入门经典(第二版)
 
#include<iostream>
using namespace std;
void gcd(int a,int b,int &d,int &x,int &y){
    if(!b){d=a;x=1;y=0;}
    else {
        gcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}
int main(){
    int a,b,d,x,y;
    while(cin>>a>>b){
     gcd(a,b,d,x,y);
     if(d!=1)cout<<"sorry"<<endl;
     else {
        while(x<0){
            x+=b;
            y-=a;
        }
        cout<<x<<" "<<y<<endl;
     }
    }
return 0;
}
View Code
 
 
 
 
 
 
原文地址:https://www.cnblogs.com/demodemo/p/4749066.html