poj 1321 棋盘问题 dfs深搜

棋盘问题
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52452 Accepted: 25350
Description


在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。要求摆放时任意的两个棋子不能放在棋盘中的同一行或者同一列,请编程求解对于给定形状和大小的棋盘,摆放k个棋子的所有可行的摆放方案C。
Input


输入含有多组测试数据。 
每组数据的第一行是两个正整数,n k,用一个空格隔开,表示了将在一个n*n的矩阵内描述棋盘,以及摆放棋子的数目。 n <= 8 , k <= n 
当为-1 -1时表示输入结束。 
随后的n行描述了棋盘的形状:每行有n个字符,其中 # 表示棋盘区域, . 表示空白区域(数据保证不出现多余的空白行或者空白列)。 
Output


对于每一组数据,给出一行输出,输出摆放的方案数目C (数据保证C<2^31)。
Sample Input


2 1
#.
.#
4 4
...#
..#.
.#..
#...
-1 -1
Sample Output


2

1

题意:找到放入k个棋子的方案数,k个棋子不能同行同列。

思路:找符合要求的方案,还是用简单的dfs

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
using namespace std;
int n,k,ans;
string s[10];
int a[10];
void dfs(int x,int l)
{

    if(l==k)
    {
        ans++;
        return;
    }
    if(x>=n)return ;
    for(int i=0; i<n; i++)
    {
        if(s[x][i]=='#'&&a[i]==0)
        {
            a[i]=1;
            //cout<<x<<i<<endl;
            dfs(x+1,l+1);
            a[i]=0;

        }
    }
    dfs(x+1,l);
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(n==k&&n==-1)
            break;
        for(int i=0; i<n; i++)
        {
            cin>>s[i];
        }
        ans=0;
        dfs(0,0);
        cout<<ans<<endl;
    }
}



原文地址:https://www.cnblogs.com/da-mei/p/9053305.html