MUTC 2 A Hero 状态压缩dp

 

Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1869    Accepted Submission(s): 868


Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

Output
Output one line for each test, indicates the minimum HP loss.
 

Sample Input
1 10 2 2 100 1 1 100
 

Sample Output
20 201
 

Author
TJU
 

Source
 

Recommend
zhuyuanchen520
 

---------------

状态压缩dp

f[S]=min(f[S+k]+sum[S+k]*hp[k])

用贪心做的都是异端啊异端!!

---------------

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

const int maxn=1<<22;
int n;
int dps[22],hp[22];
int sum[maxn];
int f[maxn];

int main()
{
    //f[S]=min(f[S+k]+sum[S+k]*hp[k]);
    while (~scanf("%d",&n))
    {
        memset(f,-1,sizeof(f));
        memset(sum,0,sizeof(sum));

        //init()
        for (int i=0;i<n;i++)
        {
            scanf("%d%d",&dps[i],&hp[i]);
        }
        //prepare()
        for (int i=0;i<(1<<n);i++)
        {
            for (int j=0;j<n;j++)
            {
                if (i&(1<<j))
                {
                    sum[i]+=dps[j];
                }
            }
        }
        //dp
        f[(1<<n)-1]=0;
        for (int s=(1<<n)-1;s>=0;s--)
        {
            for (int k=0;k<n;k++)
            {
                if (!(s&(1<<k)))
                {
                    if (f[s]==-1||f[s+(1<<k)]+sum[s+(1<<k)]*hp[k]<f[s])
                    {
                        f[s]=f[s+(1<<k)]+sum[s+(1<<k)]*hp[k];
                    }
                }
            }
        }
        printf("%d\n",f[0]);
    }
    return 0;
}







原文地址:https://www.cnblogs.com/cyendra/p/3226369.html