hdu 2767 Proving Equivalences 等价性证明 强连通分量

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1641    Accepted Submission(s): 619


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
2 4 0 3 2 1 2 1 3
 

Sample Output
4 2
 

找出强连通分量,缩点,得到DAG,设a个点入度为0,b个点出度为0,max{a,b}就是答案,原图已经强连通时,答案为0。


Tarjan算法求强连通分量

#include <iostream>
#include <vector>
#include <stack>
#include <cstring>
#include <cstdio>

using namespace std;

const int maxn=41111;

//-----Tarjan

vector<int> G[maxn];
int pre[maxn],lowlink[maxn],sccno[maxn],dfs_clock,scc_cnt;
stack<int> S;

void dfs(int u)
{
    pre[u]=lowlink[u]=++dfs_clock;
    S.push(u);
    int len=G[u].size();
    for (int i=0;i<len;i++)
    {
        int v=G[u][i];
        if (!pre[v])
        {
            dfs(v);
            lowlink[u]=min( lowlink[u], lowlink[v] );
        }
        else if (!sccno[v])
        {
            lowlink[u]=min( lowlink[u], pre[v] );
        }
    }
    if (lowlink[u]==pre[u])
    {
        scc_cnt++;
        while (true)
        {
            int x=S.top();
            S.pop();
            sccno[x]=scc_cnt;
            if (x==u) break;
        }
    }
}

void find_scc(int n)
{
    dfs_clock=scc_cnt=0;
    memset(sccno,0,sizeof(sccno));
    memset(pre,0,sizeof(pre));
    for (int i=0;i<n;i++)
    {
        if (!pre[i]) dfs(i);
    }
}

//-----------

int in0[maxn],out0[maxn];

int main()
{
    int T,n,m;
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d%d",&n,&m);
        for (int i=0;i<n;i++) G[i].clear();
        for (int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            u--;
            v--;
            G[u].push_back(v);
        }
        find_scc(n);
        for (int i=1;i<=scc_cnt;i++)
        {
            in0[i]=out0[i]=1;
        }
        for (int u=0;u<n;u++)
        {
            int len=G[u].size();
            for (int i=0;i<len;i++)
            {
                int v=G[u][i];
                if (sccno[u]!=sccno[v])
                {
                    in0[sccno[v]]=out0[sccno[u]]=0;
                }
            }
        }
        int a=0,b=0;
        for (int i=1;i<=scc_cnt;i++)
        {
            if (in0[i]) a++;
            if (out0[i]) b++;
        }
        int ans=max(a,b);
        if (scc_cnt==1) ans=0;
        printf("%d\n",ans);
    }
    return 0;
}

Kosaraju算法求强连通分量

#include <iostream>
#include <vector>
#include <stack>
#include <cstring>
#include <cstdio>

using namespace std;

const int maxn=41111;

//-----Kosaraju

vector<int>G[maxn],G2[maxn];
vector<int>S;
int vis[maxn],sccno[maxn],scc_cnt;

void dfs1(int u)
{
    if (vis[u]) return;
    vis[u]=1;
    for (int i=0;i<G[u].size();i++) dfs1(G[u][i]);
    S.push_back(u);
}

void dfs2(int u)
{
    if (sccno[u]) return;
    sccno[u]=scc_cnt;
    for (int i=0;i<G2[u].size();i++) dfs2(G2[u][i]);
}

void find_scc(int n)
{
    scc_cnt=0;
    S.clear();
    memset(sccno,0,sizeof(sccno));
    memset(vis,0,sizeof(vis));
    for (int i=0;i<n;i++) dfs1(i);
    for (int i=n-1;i>=0;i--)
    {
        if (!sccno[S[i]])
        {
            scc_cnt++;
            dfs2(S[i]);
        }
    }
}

//-----------

int in0[maxn],out0[maxn];

int main()
{
    int T,n,m;
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d%d",&n,&m);
        for (int i=0;i<n;i++)
        {
            G[i].clear();
            G2[i].clear();
        }
        for (int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            u--;
            v--;
            G[u].push_back(v);
            G2[v].push_back(u);
        }
        find_scc(n);
        for (int i=1;i<=scc_cnt;i++)
        {
            in0[i]=out0[i]=1;
        }
        for (int u=0;u<n;u++)
        {
            int len=G[u].size();
            for (int i=0;i<len;i++)
            {
                int v=G[u][i];
                if (sccno[u]!=sccno[v])
                {
                    in0[sccno[v]]=out0[sccno[u]]=0;
                }
            }
        }
        int a=0,b=0;
        for (int i=1;i<=scc_cnt;i++)
        {
            if (in0[i]) a++;
            if (out0[i]) b++;
        }
        int ans=max(a,b);
        if (scc_cnt==1) ans=0;
        printf("%d\n",ans);
    }
    return 0;
}




原文地址:https://www.cnblogs.com/cyendra/p/3038426.html