nyoj——113 getline

字符串替换

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
 
描述
编写一个程序实现将字符串中的所有"you"替换成"we"
 
输入
输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do
来源
水题比赛
上传者
hzyqazasdf
#include <bits/stdc++.h>
using namespace std;
typedef long long  ll;
const int INF = 0x3f3f3f3f;
const int maxn = 1000000;


int main()
{
    string sym;
    while(getline(cin,sym)){
        string pattern = "you";
        string add = "we";
        while(1){
            if(sym.find(pattern) > 1005)
                break;
            int pos = sym.find(pattern);
            string s1 = sym.substr(0,pos);
            string s2 = sym.substr(pos+3,sym.length()-pos-3);
            sym = s1 + add + s2;
        }
        cout << sym << endl;
    }
    return 0;
}

很简单的一道题,遇到了stl中的一个坑,ios默认读到空格为止,所以要用getline

原文地址:https://www.cnblogs.com/cunyusup/p/8526084.html