栈的使用

1205 单词翻转

 

 时间限制: 1 s
 空间限制: 128000 KB
 题目等级 : 青铜 Bronze
 
 
 
题目描述 Description

给出一个英语句子,希望你把句子里的单词顺序都翻转过来

输入描述 Input Description

输入包括一个英语句子。

输出描述 Output Description

按单词的顺序把单词倒序输出

样例输入 Sample Input

I love you

样例输出 Sample Output

you love I

#include <iostream>
#include<cmath>
#include "algorithm"
#include "cstdio"
#include "stack"
using namespace std;

int main()
{
    string a;
    stack<string>b;
    while(cin >> a)
        b.push(a);
    while(!b.empty())
    {
        cout << b.top() << " ";
        b.pop();
    }
    return 0;
}

以前学了栈不知道怎么用,今天看到竟然可以这么用。学到了

原文地址:https://www.cnblogs.com/cunyusup/p/7719119.html