PAT 1142 Maximal Clique

1142 Maximal Clique (25 分)
 

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define MAXN 10005

int G[MAXN][MAXN] = {0};
int n,m;

bool is_clique(vector<int> v){
    for(int i=0;i < v.size();i++){
        for(int j=i+1;j < v.size();j++){
            if(!G[v[i]][v[j]]) return 0;
        }
    }
    return 1;
}

bool is_exist(vector<int> v,int num){
    for(int i=0;i < v.size();i++){
        if(v[i] == num) return 1;
    }
    return 0;
}



int main(){
    cin >> n >> m;
    for(int i=0;i < m;i++){
        int x,y;
        cin >> x >> y;
        G[x][y] = 1;
        G[y][x] = 1;
    }

    int q;
    cin >> q;
    while(q--){
        int K;
        cin >> K;
        vector<int> temp;
        for(int i=0;i < K;i++){
            int nnn; cin >> nnn;
            temp.push_back(nnn);
        }



        if(is_clique(temp)){
            int flag=1;
            for(int i=1;i <= n;i++){
                if(!is_exist(temp,i)){
                    temp.push_back(i);
                    if(is_clique(temp)){
                        cout << "Not Maximal" << endl;
                        flag=0;
                        break;
                    }
                    else temp.pop_back();
                }
            }
            if(flag) cout << "Yes" << endl;
        }
        else cout << "Not a Clique" << endl;

    }

    return 0;
}

——这题都不能算图吧,太简单了。

 
原文地址:https://www.cnblogs.com/cunyusup/p/10807549.html