PAT 1144 The Missing Number

1144 The Missing Number (20 分)
 

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int a[100005];

int main(){
    int n;
    cin >>n;
    for(int i=0;i < n;i++){
        cin >> a[i];
    }

    sort(a,a+n);

    int cnt = 1;

    for(int i=0;i < n;i++){
        if(a[i] > 0){
            if(a[i]>cnt){
                cout << cnt;
                return 0;
            }
            else if(a[i] == cnt){
                cnt++;
            }
        }
    }
    cout << cnt;

    return 0;
}

做水题的感觉也太棒了8

 
原文地址:https://www.cnblogs.com/cunyusup/p/10786745.html