PAT 1054 The Dominant Color

1054 The Dominant Color (20 分)
 

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution Mby N (for example, 8), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤) and N (≤) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24


#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define MAXN 10005
map<string,int> mp;


int main(){
    int n,m;cin >> n;cin >> m;
    int num = (m*n)/2;
    for(int i=0;i < n;i++){
        for(int j=0;j < m;j++){
            string x;cin >> x;
            mp[x]++;
        }
    }
    int cnt = 0;
    for(auto it=mp.begin();it!=mp.end();it++){
        if(it->second >= num){
            if(cnt != 0) cout << " ";
            cout << it->first;
            cnt++;
        }
    }

    return 0;
}

auto 真好用

原文地址:https://www.cnblogs.com/cunyusup/p/10737072.html