HDU 1222 Wolf and Rabbit

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2968    Accepted Submission(s): 1432


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
2 1 2 2 2
 

Sample Output
NO YES
 

Author
weigang Lee
 

Source
 
网上说只需求m、n知否存在非1公约数,就是求最大公约数是否为1.我的方法不是这样。以下代码仅供参考:
AC code
#include <iostream>
using namespace std;
int main()
{
	int m,n,p;
	bool flag;
	cin>>p;
	while(p--)
	{
		cin>>m>>n;
		flag=false;
		if(m==1||n==1) {}//注意m、n均可为1
		else if(n>=m && n%m==0)
		{
			flag=true; 
		}
		else if(m>n)
		{
			if(m%n==0)	flag=true;
			else if(n%(m-(m/n)*n)==0 && m-(m/n)*n!=1) flag=true;
		}
		if(flag) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}

原文地址:https://www.cnblogs.com/cszlg/p/2910520.html