组合数学

找单词

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4093    Accepted Submission(s): 2933


Problem Description
假设有x1个字母A, x2个字母B,..... x26个字母Z,同时假设字母A的价值为1,字母B的价值为2,..... 字母Z的价值为26。那么,对于给定的字母,可以找到多少价值<=50的单词呢?单词的价值就是组成一个单词的所有字母的价值之和,比如,单词ACM的价值是1+3+14=18,单词HDU的价值是8+4+21=33。(组成的单词与排列顺序无关,比如ACM与CMA认为是同一个单词)。
 
Input
输入首先是一个整数N,代表测试实例的个数。
然后包括N行数据,每行包括26个<=20的整数x1,x2,.....x26.
 
Output
对于每个测试实例,请输出能找到的总价值<=50的单词数,每个实例的输出占一行。
 
Sample Input
2 1 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 9 2 6 2 10 2 2 5 6 1 0 2 7 0 2 2 7 5 10 6 10 2 10 6 1 9
 
Sample Output
7 379297
 
Source

Mean: 

 略

analyse:

 经典的母函数运用题。

Time complexity:O(n^3)

Source code:

// Memory   Time
// 1347K     0MS
// by : Snarl_jsb
// 2014-09-18-13.40
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<string>
#include<climits>
#include<cmath>
#define N 1000010
#define LL long long
using namespace std;

int cnt[100],c1[100],c2[100];
int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(0);
//    freopen("C:\Users\ASUS\Desktop\cin.cpp","r",stdin);
//    freopen("C:\Users\ASUS\Desktop\cout.cpp","w",stdout);
    int Cas;
    cin>>Cas;
    while(Cas--)
    {
        for(int i=1;i<=26;++i)
            cin>>cnt[i];
        memset(c1,0,sizeof(c1));   //以防后面越界,最好全部赋值为0
        memset(c2,0,sizeof(c2));
        for(int i=0;i<=cnt[1]&&i<=50;++i)
            c1[i]=1;
        for(int i=2;i<=26;++i)
        {
            for(int j=0;j<=50;++j)
            {
                for(int k=0;k+j<=50&&k<=cnt[i]*i;k+=i)
                {
                    c2[k+j]+=c1[j];
                }
            }
            for(int j=0;j<=50;++j)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        long long ans=0;
        for(int i=1;i<=50 ;++i)
            ans+=c1[i];
        cout<<ans<<endl;
    }
    return 0;
}

  

原文地址:https://www.cnblogs.com/crazyacking/p/3979112.html