(HDOJ 1018)Big Number

Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 
Sample Input
2
10
20
 
Sample Output
7
19
#include<stdio.h>
#include<math.h>

int main(){  
  int i,temp,N;
  int number;
  long double member=0;
  scanf("%d",&N);
  while(N--){
      scanf("%d",&number);
      member=0;
      for(i=1,temp=0;i<=number;i++){
          member+=log10(i*1.0);
          }
          temp=floor(member)+1;
          printf("%d\n",temp);
    }
  getchar();
  return 0;
}
原文地址:https://www.cnblogs.com/cpoint/p/2913956.html