(HDOJ 2054)A == B ?

A == B ?


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
1 2

2 2 

3 3 

4 3

 

Sample Output
NO

YES 

YES 

NO

 

  AC code:

  #include <stdio.h>

#include <string.h>

void A(char *s)
{
    
int len = strlen(s);
    
char *= s + len - 1;
    
if (strchr(s, '.'))
    
while (*== '0'*p-- = 0;
    
if (*== '.'*= 0;
}

int main(void)
{
    
char *pa, *pb;
    
char a[100024], b[100024];

    
while (scanf("%s%s"&a, &b) != EOF)
    {
        pa 
= a; pb = b;
        
while (*pa == '0') pa++;
        
while (*pb == '0') pb++;
        A(pa); A(pb);
        puts(strcmp(pa, pb) 
? "NO" : "YES");
    }

    
return 0;
}
作者:cpoint
本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.
原文地址:https://www.cnblogs.com/cpoint/p/2026616.html