HDU Problem 1312 Red and Black 【DFS】

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17430    Accepted Submission(s): 10577


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1241 1016 1010 1372 1253 
 

图的遍历问题,用DFS比价方便。


#include<iostream>
#include<cstring>
using namespace std;

int disx,disy;
char map[30][30];
int dfs(int i,int j) {
    if(i<0||i>=disy||j<0||j>=disx) return 0;
    if(map[i][j] != '#') {
        map[i][j] = '#';
        return 1+dfs(i-1,j)+dfs(i+1,j)+dfs(i,j-1)+dfs(i,j+1);
    }
    else  return 0;
}
int main() {
    int n, m, p, j, i, l, k;
    while(cin>>disx>>disy) {
       if((disx == 0) && (disy == 0))  return 0;
         for(i = 0; i < disy; i++) {
            for(j = 0; j < disx; j++) {
                cin>>map[i][j]; 
                 if(map[i][j]=='@') {
                    p=i; k=j;
                } 
             }
         }
         m=dfs(p,k);
         cout<<m<<endl;
    }
    return 0;
} 
原文地址:https://www.cnblogs.com/cniwoq/p/6770895.html