HDU 1312 Red and Black (深搜)

题目链接

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

分析:

只能够走‘.’,递归到最后,看一共有多少个可以走。

代码:

#include <iostream>
#include<string.h>
using namespace std;
int m,n;
int Next[4][2]= {{0,1},{1,0},{0,-1},{-1,0}};

int bj[21][21];
char a[21][21];
int sum=0;
void dfs(int x,int y)
{
    int nx,ny;
    for(int i=0; i<4; i++)
    {
        nx=x+Next[i][0];
        ny=y+Next[i][1];
        if(a[nx][ny]=='.'&&nx>=0&&nx<m&&ny>=0&&ny<n&&bj[nx][ny]==0)
        {
            bj[nx][ny]=1;
            sum++;
            dfs(nx,ny);
        }
    }
}

int main()
{
    int i,j,x,y;
    while(cin>>n>>m)
    {
        if(m==0||n==0)
            break;
        for(i=0; i<m; i++)
            for(j=0; j<n; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='@')
                {
                    x=i;
                    y=j;
                }
            }
        memset(bj,0,sizeof(bj));
        sum=1;
        dfs(x,y);
        cout<<sum<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/cmmdc/p/6767987.html