POJ 1753 Flip Game (DFS)

Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32104   Accepted: 13988

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

 
这道题让我想起了hdu 2209的翻纸牌游戏,都是翻转,但是那个是一维的相对这道题来说简单很多
这道确实不知道怎么搜,最开始是想应该是写两个DFS分别判断是否是全黑或者全白的情况,但是不明白的是怎么才能算是impossible
后来看了别人的思路之后慢慢理清思路了,因为每个棋子应该是翻转奇数次的,如果翻转偶数次的话,就相当于周围的棋子没有变化,
那么最多就有16步了,整个棋盘最多2^16种情况
按步数去枚举的话,思路就清晰多了
如果超过16步的话,那就是无解了,如果能在16之内找出解,输出即可。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<algorithm>
#define LL __int64
using namespace std;
const int MAXN=5+5;
const int INF=0x3f3f3f3f;
const double EPS=1e-9;
int dir4[][2]={{0,1},{1,0},{0,-1},{-1,0}};
int dir8[][2]={{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1}};
int dir_8[][2]={{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};
int map[6][6],step;
bool flag;
char temp;

bool judge()
{
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
            if(map[i][j]!=map[0][0])
                return false;
    return true;
}

void turn(int x,int y)
{
    map[x][y]=!map[x][y];
    for(int i=0;i<4;i++)
    {
        int xx=x+dir4[i][0];
        int yy=y+dir4[i][1];
        map[xx][yy]=!map[xx][yy];
    }
}

void DFS(int x,int y,int cur)
{
    if(cur==step)
    {
        flag=judge();
        return ;
    }
    if(x==4||flag) return ;

    turn(x,y);
    if(y==3)
        DFS(x+1,0,cur+1);
    else
        DFS(x,y+1,cur+1);

    turn(x,y);
    if(y==3)
        DFS(x+1,0,cur);
    else
        DFS(x,y+1,cur);

    return ;
}
int main()
{
    //freopen("in.txt","r",stdin);
    for(int i=0;i<4;i++)
    {
        for(int j=0;j<4;j++)
        {
            scanf("%c",&temp);
            if(temp=='b')
                map[i][j]=1;
        }
        getchar();
    }

    flag=false;
    for(step=0;step<=16;step++)
    {
        DFS(0,0,0);
        if(flag) break;
    }

    if(flag)
        cout<<step<<endl;
    else
        cout<<"Impossible"<<endl;
}
View Code
原文地址:https://www.cnblogs.com/clliff/p/4239982.html