uva514Rails

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has  coaches numbered in increasing order . The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be . Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input 
The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of  The last line of the block contains just 0.
The last block consists of just one line containing 0.

Output 
The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.
Sample Input 
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output 
Yes
No

Yes

用栈来实现火车站的模拟
火车站中存在的三种操作:
1. 直接从站里出来
2. 进站,暂时不出来
3. 第一个进站的火车出来
因此要判断火车是否能按找指定的顺序出来也有三种情况:
1.火车正好和应该出栈的火车一样,直接出栈
2.栈顶的火车正好和应该出栈的火车相同,栈顶火车出栈
3.火车和以上两种情况都不相符,而且,还有火车没有进站

注意:此题虽然很好理解,但是这个题的输入输出形式比较坑,需要注意下

#include<bits/stdc++.h>
#include<stack>
using namespace std;
const int N = 1e6+10;
int a[N];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n) {
        stack<int> s;
        int x,y,flag;
        while(cin>>a[1] && a[1]) {
            for(int i = 2; i <= n; i++) {
                cin>>a[i];
            }
            x = y = flag = 1;
            while(y <= n) {
                if(x == a[y]) {
                    x++;
                    y++;
                }
                else if(!s.empty() && s.top() == a[y]) {
                    s.pop();
                    y++;
                }
                else if(x <= n) {
                    s.push(x++);
                }
                else {
                    flag = 0;
                    break;
                }
            }
            if(flag)
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
        }
        cout<<endl;
    }
}

  

原文地址:https://www.cnblogs.com/clb123/p/12328002.html