poj 1456 Supermarket

Description
A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2  5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
 
题意: 有N件商品,知道了商品的价值和销售的最后期限,只要在最后日期之前销售处,就能得到相应的利润,并且每天只能销售一件商品,求出最大利润
 
思路:并查集加贪心,先把所有产品按照利润从大到小排序,然后把这个放在截止日期那天卖出,并做好标记,如果截至日期那天已经有其他产品占用了,那么可以把这个产品卖出的时间往前推,直到找到可以卖的那一天并标记好,用并查集的关键之处是,我们知道按照上面那个方法,假设一个产品a占用了一个日期后,那么如果下次又有一个产品b和产品a的截止日期是相同的,但是那个日期以被占用了,所以就要往前移动1天,那么就可以用并查集进行标记,在a占用了那个日期后,把a的截止日期指向前一个日期,这样的话,可以直接查找到他要占用到哪一个时间。 
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;

const int N = 1e4+10;
int f[N];

struct node
{
	int p;
	int d;
}a[N];

bool cmp(node a1,node a2)    //利润从大到小排序
{
	return a1.p>a2.p;
}

int find(int x)
{
	if(f[x] == x) {
		return x;
	}
	return f[x]=find(f[x]);
}

int main()
{
	int n;
	while(cin>>n) {
        for(int i = 0; i < N; i++) {
        	f[i] = i;
        }
		for(int i = 0; i < n; i++)
			cin >> a[i].p >> a[i].d;
		sort(a, a+n, cmp);
		int sum = 0;
		for(int i = 0; i < n; i++) {
			int x = find(a[i].d);
			if(x > 0) {
				f[x] = x-1;     //该商品已经用了这一天,所以其他商品要用的话只能提前,所以-1
				sum += a[i].p;
			}
		}
	    cout<<sum<<endl;
	}
	return 0;
}

  

 

 
原文地址:https://www.cnblogs.com/clb123/p/11201851.html