PAT(A) 1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
#include <fstream>
using namespace std;
#include <cstdio>

const int MAXN=1005;
double poly[MAXN]={};   //多项式系数全都初始化为0

int main()
{
    int k, exp, cnt=0;
    double coef;
    scanf("%d", &k);
    for(int i=0; i<k; i++){
        scanf("%d%lf", &exp, &coef);
        poly[exp] += coef;
    }
    scanf("%d", &k);
    for(int i=0; i<k; i++){
        scanf("%d%lf", &exp, &coef);
        poly[exp] += coef;
    }
    for(int i=0; i<MAXN; i++){
        if(poly[i]!=0)
            cnt++;
    }
    printf("%d", cnt);
    for(int i=MAXN-1; i>=0; i--){
        if(poly[i]!=0)
            printf(" %d %.1lf", i, poly[i]);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/claremore/p/6530174.html