PTA 5-3 Pop Sequence (25)

题目:http://www.patest.cn/contests/pat-a-practise/1051

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
题目描述:

一列数, 只能以1, 2, …., N 的顺序push 到stack里面, 但是可以再任意时刻pop出一个数字.
给定一个序列, 看是否可以按照这样的规则得到一个pop序列.

算法分析:

从1开始,与栈顶元素不等,则压栈
压栈后若超过栈的大小,则不满足题目条件
栈顶==input时 出栈

#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;

int main(int argc, char** argv)
{
    int m,n,k;
    cin >> m >> n >> k;
    for(int i=0; i<k; i++)  //测试k组出栈顺序是否满足条件
    {
        stack <int> s;
        int input,temp=1;   //从 temp=1开始依次压栈
        bool flag=true;
        for(int j=0; j<n; j++)
        {
            cin >> input;
            if(flag)        //判断是否已经不满足条件,当前满足才继续
            {
                while(s.empty() || s.top()!=input)  //与栈顶元素不等,则压栈
                {
                    s.push(temp);
                    if((int)(s.size())>m)  //压栈后若超过栈的大小则不满足题目条件
                    {
                        flag=false;
                        break;
                    }
                    temp++;
                }
                if(flag && s.size()>0 && s.top()==input)    //栈顶==input 出栈
                    s.pop();
            }
        }//for 一组结束
        if(flag)
            cout << "YES" << endl;
        else
            cout << "NO" << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/claremore/p/4803892.html