HDOJ Oulipo 1686【KMP】

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7200    Accepted Submission(s): 2867


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 


 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 


 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 


 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 


 

Sample Output
1 3 0
 


 

Source
 


 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1358 3336 3746 3068 2222 

KMP模板题。注意k的赋值,题目要求是包括几个 不是能切割几个。如asdasd      asdasdasd   这样的情况下结果应该是2  所以当k==plen后再计算,k的赋值不能从0再開始,而是从pre[k]開始。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 1000000+10

using namespace std;

int pre[maxn];
char T[maxn];
char P[10010];

void getpre(int plen)
{
    pre[0]=pre[1]=0;
    for(int i=1;i<plen;i++){
        int k=pre[i];
        while(k&&P[i]!=P[k])k=pre[k];
        pre[i+1]=P[i]==P[k]?

k+1:0; } } int search(int slen,int plen) { int num=0; getpre(plen); int k=0; for(int i=0;i<slen;i++){ while(k&&P[k]!=T[i])k=pre[k]; if(P[k]==T[i])k++; if(k==plen){ ++num; k=pre[k]; //从0開始是挪动了plen。题目是找出包括几个,不是能切割几个。所以从pre[k]開始。 } } return num; } int main() { int t; scanf("%d",&t); while(t--){ memset(pre,0,sizeof(pre)); scanf("%s%s",P,T); int slen=strlen(T); int plen=strlen(P); int res=search(slen,plen); printf("%d ",res); } return 0; }


 

原文地址:https://www.cnblogs.com/claireyuancy/p/6789686.html