杭电ACM1.2.2 Buildings

Buildings

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1604 Accepted Submission(s): 1175
 

Problem Description

We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.

 

 

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.

 

Output


            Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.

 

Sample Input

2

2 2

1 1

0 0

3 3

1 0 1

0 0 1

1 1 0

 

Sample Output

2

5

代码:

#include<iostream>
using namespace std;

int main()
{
     int j,N,M,n,i,a;
     cin>>n;
     while((n--)&&(n<=100))
     {
          int count=0;
          cin>>N>>M;
          for(i=1;i<=N;i++)
          {
               for(j=1;j<=M;j++)
               {
                    cin>>a;
                    if(a==1)
                         ++count;    
               }
          }
          cout<<count<<endl;    
     }
    
     return 0;
}
原文地址:https://www.cnblogs.com/cityflickr/p/3133022.html