杭电ACM1.2.1 Elevator

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12561 Accepted Submission(s): 7364
 

Problem Description

Your task is to Calculate the sum of some integers.

 

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

 

Sample Input

4 1 2 3 4

5 1 2 3 4 5

0

 

Sample Output

10

15

代码:

#include<iostream>
using namespace std;

int main()
{
     int N,i,a,c[100];
     while(cin>>N&&N&&(N<100))
     {
          c[0]=0;
          int sum=0;
          for(i=1;i<=N;i++)
          {
               cin>>a;
               c[i]=a;
               if(c[i]>c[i-1])
                    sum+=5+(c[i]-c[i-1])*6;
               else if(c[i]<c[i-1])
                    sum+=5+(c[i-1]-c[i])*4;
               else
                    sum+=5;
          }
          cout<<sum<<endl;    
     }
    
     return 0;
}
原文地址:https://www.cnblogs.com/cityflickr/p/3133016.html