杭电ACM1.1.5

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9460 Accepted Submission(s): 7051
 

Problem Description

Your task is to calculate the sum of some integers.

 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

 

Sample Input

2

4 1 2 3 4

5 1 2 3 4 5

 

Sample Output

10

15

代码:

#include<iostream>
using namespace std;

int main()
{
     int N,i,M;
     cin>>M;
     while(cin>>N&&N&&M--)
     {
          int sum=0,a;
          while(N--&&cin>>a)
          {
               sum+=a;
          }    
          cout<<sum<<endl;    
     }
    
     return 0;
}
原文地址:https://www.cnblogs.com/cityflickr/p/3132762.html