Sum of divisors

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=25019#problem/C

 

Description

mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!
But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?" mmm get stuck and she's asking for your help.
Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different.
Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.
 

Input

Multiple test cases, each test cases is one line with two integers.
n and m.(n, m would be given in 10-based)
1≤n≤109
2≤m≤16
There are less then 10 test cases.
 

Output

Output the answer base m.
 

Sample Input

10 2 30 5
 

Sample Output

110 112
 
 
坑爹啊,按照题目先把因数进行进制转换后再求和就会错,不知道为什么
查了一下才知道,其实因数求出来后直接mod 进制来求和会简单一点。
另外刚开始是TL,想到了枚举到sqrt(n)就行,不过没尝试,后来看别人的代码才知道这是对的。
 
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cctype>
#include <string>
using namespace std;

string to_other(int x, int base)
{
    string ans;
    
    char temp;
    
    while (x)
    {
        if (x%base >= 10)
            temp = (x%base-10)+'A';
        else 
            temp = x%base+'0';
            
        ans = temp + ans;
        
        x /= base;
    }
    
    return ans;
}


int main()
{
    int n, m;
    
    while (scanf("%d%d", &n, &m) != EOF)
    {
        int sum = 0;
        
        for (int i = 1; i <= (int)sqrt((double)n); ++i)
        {
            if (n%i == 0)
            {
                int temp = i;
                
                while (temp)
                {
                    sum += (temp%m)*(temp%m);
                    
                    temp /= m;
                }
                
                if (n/i == i)    break;
                
                temp = n/i;
                
                while (temp)
                {
                    sum += (temp%m)*(temp%m);
                    
                    temp /= m;
                }
            }
        }
        
        cout << to_other(sum, m) << endl;
    }
}
View Code
原文地址:https://www.cnblogs.com/chenyg32/p/3136755.html