poj 2533 (LIS 最长递增子序列)

采用的是 O(nlogn) 的算法。

算法的关键是: 用一个数组g[i] 记录当前有i个元素的递增子序列的最后一个元素的最小值,因为g是单调的,所以可以用二分.

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 25957   Accepted: 11274

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
#define N 1010

int g[N];

int main()
{
    int n;
    scanf("%d",&n);
    int cnt=0;
    memset(g,-1,sizeof(g));
    int k=0;
    for(int i=1;i<=n;i++)
    {
        int tmp;
        scanf("%d",&tmp);
        int b=0,d=k;
        while(b<d)
        {
            int mid=(b+d+1)/2;
            if(tmp > g[mid])
            {
                b = mid;
            }
            else
            {
                d = mid-1;
            }
        }
        if(g[b+1]==-1) g[b+1]=tmp;
        else g[b+1]=min(g[b+1],tmp);
        if(b+1>k) k=b+1;
    }
    printf("%d\n",k);
    return 0;
}
原文地址:https://www.cnblogs.com/chenhuan001/p/2979760.html